Scan-IT to Office 常见问题
如何将表单数据发送到不同的工作表
如何将表单数据发送到不同的工作表
有时,您可能希望创建多个表单,并将每个表单分别发送到电子表格中各自专属的工作表。
这可以通过 Excel 中的宏,或 Google 表格中的 Google Apps 脚本来实现。
只需在表单中添加一个带有分类标识符的静态文本字段,宏/脚本便可识别所采集数据的分类,并自动将其移动到目标工作表中。
Scan-IT to Office 应用:
- 新增两个表单,或编辑您现有的表单,并在每个表单中添加一个“静态文本”字段。
- 将“静态文本”字段的值设置为您所需的分类名称
(在此示例中,我们使用了“Cat1”和“Cat2”)。 - 请确保“静态文本”字段是表单中的第一个字段。
- 您也可以考虑将“静态文本”字段隐藏起来。

Microsoft Excel:
- 下载示例电子表格并在 Excel 中打开。
- 插入 Scan-IT to Office 加载项。
- 在加载项选项中选择“Insert after last non-empty row”(插入到最后一个非空行之后),并确保已选中“ScanData”。
- 打开“Categories”工作表,将“Category”下的值改为与“静态文本”字段的值相匹配。
- 如果您想重命名工作表,也需要相应地更改“Sheet”下的值。
- 注意:请勿重命名“ScanData”工作表和“Categories”工作表,否则宏将无法正常工作。

Google 表格:
- 打开我们的示例电子表格。
- 选择“文件” -> “制作副本”,以创建一份可编辑的示例副本。
- 打开脚本编辑器,选择“工具” -> “脚本编辑器”。
- 在脚本编辑器中为该工作表添加一个新触发器
“编辑” -> “当前项目的触发器” -> “+ 添加触发器”
将“选择事件来源”改为“变更时”,然后保存更改。 - 将 Scan-IT to Office 加载项插入电子表格,或通过 Google 表格 (Drive) 连接方式连接到“ScanData”工作表。
- 如果您使用的是加载项,请在加载项选项中选择“Insert after last non-empty row”(插入到最后一个非空行之后),并确保已选中“ScanData”。
- 打开“Categories”工作表,将“Category”下的值改为与“静态文本”字段的值相匹配。
- 如果您想重命名工作表,也需要相应地更改“Sheet”下的值。
- 注意:请勿重命名“ScanData”工作表和“Categories”工作表,否则 Google 脚本将无法正常工作。